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This tutorial will use the PREKIN kinemage construction program and 
the KING kinemage viewing/editing program. All software is available 
at kinemage.biochem.duke.edu 
 
Obtain the ricin protein databank file at http://www.rcsb.org/pdb/ 
Search for 2AAI. Then Download/Display→ Download the structure file 
→ Right mouse click on PDB file format (no compression). Save target 
as 2AAI on your desktop.  
 
 KINEMAGE 1- Overview of the molecule   
To start - a simple alpha carbon backbone kinemage 
    For an initial look at the ricin molecule, we will run a simple default script on file 
2AAI.pdb.  Launch (i.e. start) PREKIN and open 2AAI.pdb from its menu. PREKIN will 
ask for an output file name, so call the output file backbone.kin. When the first dialog 
box of choices comes up, accept the default "Backbone browsing script", which will 
execute a simple script producing Calphas (a connected series of alpha carbons), 
disulfides, and non-water het groups for all subunits in the file. A ‘het’ group is anything 
not part of the polypeptide (or polynucleotide) chain. When PREKIN is done, launch 
KING and open the resulting kinemage. 

Comment [BB1]: Tip: Pay attention to 
where your file is being saved. It is easy 
to accidentally lose a file by saving to the 
wrong directory.

 
You should see Calpha backbones for the two ricin chains in different colors, with yellow 
disulfides and several bound sugars (pink).  Move the image around by dragging with the 
mouse.  Such a simple, default kinemage shows many of the features of the structure, and 
is useful for many purposes.  Note, however, that the viewpoint is arbitrary and the 
default colors, names, and arrangement of buttons are not ideal.  If you want to show 
particular details and express your point clearly to someone unfamiliar with the structure, 
then there are many ways to make the kinemage more informative and persuasive.  
 
Choosing and saving views in KING 
    In this section you will prepare a 3-D portrait of the ricin molecule and similar 
portraits of each of the two individual subunits (chains). 
    Creating an overview: First move the image around to find a view that spreads out the 
three domains in the plane of the screen, with the A chain (the white one) at the top.  See 
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if you can enlarge the zoom factor by one or two arrow-clicks on the zoom slider without 
going off the screen edges.  Type ‘s’ on the keyboard to toggle into stereo, to make sure 
your zoom and orientation allow seeing most of the important parts in stereo (you can 
check for that, even if you can't see stereo yourself). Re-center if needed by right mouse 
clicking on the atom you want in the center of the screen.  Alternately, you can hold 
down the control key and drag the structure around with the mouse. Once satisfied, 
choose “Save Current View” under the Views menu, and save the view as a descriptive 
name such as "overview".  Move the image, then choose “overview” under the View 
menu, which should reproduce the view you just saved. 
   
    Creating views of subunit features: Right click on an atom near the middle of the A 
chain and zoom in somewhat.  Check the “markers” box at the bottom of the window, 
then choose the "Find Point" function under the Edit menu.  In the dialog box ask to 
search for " 177 ", which is the active-site Glu of ricin;  KING will center on Glu 177 and 
mark it with a box. Choose a view for the A chain that shows both the central beta sheet 
and this active-site Glu, and save the view as "A chain".  Now pickcenter between the 
two domains of the B chain, zoom in, and save a view that shows the domains fairly 
equivalently, in a vertical orientation to allow for stereo. It might help to unclick the A 
chain button so you can see the B chain better, although your view shouldn’t absolutely 
require that since your readers may not think of doing it. 
 
Renaming and coloring groups: Go Tools -> Kin editing -> edit properties, and click 
on any sugar atom.  The resulting dialog box will show you the program's internal data 
structure for this atom.  Click the “edit group” button and name the group  "sugars".   
Accept the result, and see how the buttons have changed. In the same way, edit the group 
names for the protein, from 2AAIa and 2AAIb to "Ricin A chain" and "Ricin B chain" 
(remember that you only get about 11 characters for a group button name).  
 
   Go Tools -> Kin editing -> recolor kins and click “color all”. Now you need to change 
the colors of the two subunits, A to differ from the red sugars and B to contrast better 
with the yellow SS bonds.  The "tint" colors work best for Calpha backbones, because 
they can be distinguished without overwhelming small features you want to emphasize.  
Make the A chain yellowtint and the B chain greentint (try out some other possibilities, 
too) by choosing the color from the dropdown menu and then clicking on an atom in the 
chain. To get out, close the recolor box and then turn off the kin editor by clicking Tools-
> Navigate. 
 
Saving your modified kinemage: Choose "Save as", under the File menu;  you will be 
given a dialog box to place and name the saved file. You will notice that the file ends in 
".2.kin" rather than ".kin".  This simply means that it is the second modification of the 
original kinemage. Quit out of KING.   
 



Highlighting important features of the protein 
    In this section you will highlight one important feature of the active site of the ricin 
molecule, the active site Glutamate 177 sidechain in the A chain. 
 
   Adding the active site Glutamate: Use PREKIN to open the 2AAI.pdb file again, but 
this time name the output file “sidechain.kin".  In the initial dialog box of PREKIN, 
choose "New Ranges".  In the range dialog specify both start and end residue as 177, 
check the 'sc' (sidechain) and 'at' (balls for non-C atoms) boxes, the "OK accepts and ends 
ranges" button, and the OK button.  In the following dialogs accept the defaults for no 
focus and 0.2A balls. In the last dialog window ask for "only first subunit" by making 
sure both entry windows have a 1 in them and the middle radio button is checked.  When 
the program quits running, you have generated a side chain for Glu 177 of the A chain.  
 
Merging files in KING :  Now launch KING with your backbone.kip file, then choose 
"Append" on the File menu to add in the sidechain.kin.  This merges the two kinemages 
into one. Change the color of the Glu 177 sidechain vectors to something bright, 
contrasting, and oxygenish, such as pink or hotpink. Rename the appropriate 2AAI 
button as Glu 177. 
 
    Look at the resulting kinemage to see if you did what you intended and whether you 
like the results.  Modify views if needed, and note anything that needs to be changed 
during future editing. Before you save the completed kinemage, return to view 1 and 
make sure all of the buttons needed for this initial view are checked. You can edit the 
order and names of views by going Views->Edit saved views. Save the completed 
kinemage as ricin1.kin. 
 
KINEMAGE 2- Secondary Structure in the A Chain 
 
Highlighting secondary structure with ribbons 
   The alpha helices and beta sheets are easiest to visualize by portraying them as ribbons, 
which is an artificial but useful construct. PREKIN has a built-in script which reads the 
secondary structure information at the top of the original PDB file and uses it to construct 
the ribbons for the backbone. 

    
Running the built-in ribbon script: Make a new 
kinemage by launching PREKIN and again selecting 
the 2AAI.pdb. Save output in the desired directory 
with the name “ricin2.kin”. Select the “built-in 
scripts” menu, then the “ribbon: HELIX_SHEET” 
option. Accept all defaults in the “ribbon” box. In 
the “run conditions” box only select the first subunit 
(A chain) by clicking the middle radio button and 
then OK. When done and before exiting, select “new 
pass” under the file menu and again select “built-in 
scripts”. This time select the “mcHb” script. OK and 
again select the first subunit in the “run conditions” 
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box. Launch KING at the end to see the created kinemage. You will have two 
representations of the A chain overlayed. In the ribbon structure, beta sheets should be 
green arrows and alpha helices gold spirals. Irregular secondary structure, i.e. coils and 
turns, will be connecting ropes. In the mainchain structure you will see the peptide 
backbone and hydrogen bonding.  
 
Using animations as alternate views of structure 
   Animating between two different representations of an object can be very informative, 
even more so if they have different conformations.  You have made two different 
representations of the ricin A chain: a line tracing of the peptide backbone, and a ribbon 
diagram of the secondary structures.  Next you will overlay and animate between these 
two representations.  KING allows animations between groups using the hierarchy editor. 
 
   While viewing ricin2.kin in KING you can set up an animation between the two 
versions of the A chain. The top button will be the ribbon structure. Unclick the group 
buttons if you are unsure. Now open the hierarchy editor (under edit) and change the 
name of the ribbon structure from “2AAIa” to “ribbons A”. Make sure the “dominant” 
and “animate” boxes are checked, then accept changes. Do the same with the other group 
except change the group name to “*mainchain”. Accept changes and turn off the 
hierarchy editor. You have now created an animation between two representations of the 
A chain. Hit the ‘a’ key on the keyboard or click the ANIMATE button on the bottom left 
of the graphics window to see the two representations. Save some good views of the 
helices and the central beta sheet. Is the sheet parallel or antiparallel? Can you follow the 
polypeptide chain as it wanders in and out of the beta sheet? Can you pick out the 
secondary structure in the mainchain kinemage alone? 
 
 
KINEMAGE 3 - Active site, with hydrogen bonds 
    The philosophy behind kinemages is that the most revealing way to illustrate what is 
important is to remove extraneous parts of the structure. In this kinemage, you will 
concentrate on the active site of ricin, which resides solely in the A chain. To see what is 
going on at the active site, you will eliminate everything that is not within 12 angstroms 
of the critical active site residue Glu 177, which you highlighted in the first kinemage. 
Before beginning, I suggest you review your amino acid sidechains so that you will 
recognize them easily. 
 
Generating an active site with the Focus option 
      Run PREKIN on file 2AAI.pdb again, with output file actsite.kin.  Choose “New 
Ranges” , then check the ‘mc’, ‘sc’, ‘at’ and the ‘OK accepts and ends ranges’ buttons. 
Hit “OK”. In the next dialog box, choose to do the focus on a residue by number.  In the 
"Focus Point Values" dialog, specify residue 177;  for radii try 8A for sidechains, 12A for 
main chain, and 0 for everything else;  ignore the special logic controls.  Do only first 
subunit.  When it finishes, launch the kinemage.  
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Cleaning up the kinemage 
    Drawing hydrogen bonds: Choose and keep a view that gives a good close-up of the 
active site.  Find the sidechains Glu 177 and 208, as well as the Gln, the two Tyr, the 
Arg, and the Trp that surround the two glutamates.  In Tools->kin editing->draw & 
delete, set “shorten lines to” 0.7.  Draw in the Hbonds from the sidechains of Arg, Trp, 
and one Tyr to the closest mainchain carbonyl oxygens  (the carbonyl of the peptide 
bond). It is helpful to zoom in on each side chain and measure the distances to the nearest 
oxygen. Remember that Hbonds are 3Å or less between atoms that share the hydrogen. 
 
    Pruning main chain: Now, in the same “draw & delete” menu, experiment using 
“punch”, “prune” and “augar” to trim away all extraneous main chain that is either 
floating in space in bits or nowhere near the sidechains or Hbonds. If you want, prune 
away any uninteresting sidechains also. Use the “undo” button to recover from mistakes.  
 
    Save a view of each sidechain hydrogen bond, remembering to use descriptive titles 
for each view. Finally, save the modified kinemage to your hard drive as ricin2.kin.  
 
 
KINEMAGE 4 – Superimposing the two domains of ricin chain B 
    Chain B has two domains that each have the "beta trefoil" fold;  superimposing them 
can show how similar they really are.  We will use the beta strands and the Trp 
sidechains as landmarks for doing the superposition in KING with its docking function. 
 
     Using the 2aai PDB file as input to PREKIN and naming the output file ricin4.kin, go 
to "New Ranges".  Since the N-terminal tail is not equivalent and the changeover point 
between the domains is at about residue 138, specify numbers 7 to 138 for the range of 
domain 1, check "ca", and hit OK.  Leave 7-138, replace the "..." with "css" (to get the 
disulfides), uncheck "ca", check "sc", and hit OK.  Leave 7-138 and "sc", replace "..." 
with "trp", but this time check "OK accepts and ends ranges" before hitting OK.  No 
focus.  Check the "Do subunits in range above" radio button and specify subunits 2 to 2.  
When PREKIN is done, choose "New Pass" from the File menu.  In "New Ranges", do 
exactly the same three ranges as above, but for residues 138 to 9999 (to get domain 2).  
This time, when PREKIN is done, launch the kinemage in KING. 
 
     You should see all of chain B, with Trp sidechains in cyan and SS in yellow.  Turn off 
the second button on the button panel (domain 2) and use "Change color" to make the 
domain 1 Calphas white.  Drag with the mouse down and then a little left to get a view 
down the 3-fold axis of domain 1 - you should see three Trp sidechains as symmetrical 
"T" shapes, with a triangle of Calpha strands evenly around a central opening.  Save this 
view as View1.  There are two other Trp in domain 1 that are not symmetrically related 
around the 3-fold;  use "Prune" to delete them.  Turn on domain 2 and make its Calphas 
some other color (maybe pinktint).  Give the two groups names like "B dom1" and "B 
dom2".  Find the 3 symmetrical Trp in domain 2, and prune away the extra, fourth one. 
 
    Find a view where the two domains are side by side and the three Trp sidechains in 
each are in roughly the same orientation. Turn on Tools->kin editing-> dock 3 on 3. Now 
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zoom in on the left domain so that you can clearly see the Trp sidechain connections to 
the alpha carbon backbone. Click on these alpha carbon connections in a clockwise 
fashion. You should see all three atom identifiers appear in the docking box. This is the 
reference structure. Repeat this procedure with the second domain, which will be the 
mobile structure. Now unclick the group button for the reference domain and click the 
“dock visible on invisible” button in the docking box. The mobile structure should jump 
into the space occupied by the reference structure. Turn on the reference structure again 
and you should see the overlay. 
 
     Use "Save as" to save the kinemage with your superimposed coordinates.  Can you 
indeed see convincingly that these two domains have the same fold?  They are almost 
certainly related by a gene duplication.  Animate between the two structures, using the 
hierarchy editor to change the properties of the two group names. You have now made 
four kinemages that illustrate a number of interesting things about ricin.  
Congratulations! 
 
Writing text in the text window and merging kinemages. 
    To add text to the text windows of any of your kinemages, simply click into the text 
window and type as if in a text editor. Right click with the mouse shows the 
cut/copy/paste mouse menu.  
To place all four of your kinemages in one file, simply open them sequentially in KING. 
Once they are all open, save as a new kinemage. 


